MENU
Lake-Link Home
LOGIN
Lake-Link
LOG IN

My lowarance is powering on by itself.

8/1/14 @ 1:00 PM
ORIGNAL POST
swamphunter
swamphunter
User since 2/12/02
I have a lowrance 332c which is 7 yrs old. Just the other day it started to power on by itself. I could hear the unit beeping under the cover. It is wired straight to a battery and not on an accessory switch. What's going on? I have since removed the locator from the boat until i can figure it out.

DISPLAYING 1 TO 7 OF 7 POSTS
FILTER OPTIONS
9/14/14 @ 7:57 AM
25427
User since 5/12/09
I have a 998 which is 2 or 3 years old. The latch cover for sd cards is off waiting repair. When the cover is tightly secured , I believe the cover hits the power button.

9/2/14 @ 10:07 PM
Rae
User since 6/19/01
swamp, I also have a 332 that I got almost 10 years ago that 3 years ago did the same thing. I just unplug it after each use, problem solved

8/3/14 @ 2:39 PM
HardCore Walleye
HardCore Walleye
User since 4/17/08
X102c does same thing. I just keep the power plug pulled out until I use it. I leave the transducer plug hooked up. Or you can put a switch in to kill power. Common occurrence with older Lowrance products!!

8/3/14 @ 10:47 AM
fishs
User since 2/17/04
Just had a 102(332 without gps)go bad. Unit would not shut off. Took the unit apart and discovered water had somehow got in and caused corrosion which of coarse does not go well with electronics. I'm guessing that is your problem. Take the torques screws off the back and see what the inside looks like. Not difficult at all. It is not a sealed unit except for the touch pad.

8/1/14 @ 7:44 PM
wet-net
User since 1/8/03
Try a soft reset Then do a hard reset if you need to

8/1/14 @ 4:58 PM
trackerrat
trackerrat
User since 7/12/06
More than likely a bad power button. I had a few eagles back in the day that would turn on and then off by themself.

DISPLAYING 1 TO 7 OF 7 POSTS
Advertise here
Advertise here
Please take a moment to visit our sponsors. Without them we would not be here.