MENU
Lake-Link Home
LOGIN
Lake-Link
LOG IN

Electronics Question?

7/28/17 @ 6:47 AM
ORIGNAL POST
Hildy Boys
Hildy Boys
User since 12/14/09

Quick question for you all.  I just bought a used boat and so far everything is great.  But I am having a problem with the trolling motor and dpeth finder.  When I run the trolling motor over 3 speed the depth finder turns off.  What do you think my issue is? 

Thanks Guys



DISPLAYING 1 TO 7 OF 7 POSTS
FILTER OPTIONS
7/29/17 @ 7:07 AM
Major Mark
Major Mark
MEMBER since 5/20/05

I'd run a starting or dual purpose battery.  Charging would depend on how much you run the big motor & output of it's charging system.  I always have my boat plugged in whenever not on the water.  I have a 3 bank "maintainer" charger, 2 leads going to my 2 trolling batteries, one lead going to accessory battery.   IF you have a dedicated battery(s) just for the trolling motor, they need to be charged somehow, and rarely are connected to the main motor electrical system.

7/29/17 @ 6:08 AM
Hildy Boys
Hildy Boys
User since 12/14/09
It was a bad battery so hopefully my new battery will solve my issue.  So another quick question.  Sounds like people run their depth finder off their starting battery.  Is that just a standard starting battery or deep cycle?  Also, does the motor run enough to still keep it charged if you run a depth finder off it or do you have to charge when you get home?

7/28/17 @ 7:59 AM
Major Mark
Major Mark
MEMBER since 5/20/05

a good battery is somewhere around 13.6 volts fully charged.  If your display says only 10v, then that battery needs charging or is ready for replacement.  Also, it is NEVER a good idea to run a locator off the same battery as an electric trolling motor.  Your asking for interference issues.

7/8/10 @ 11:12 AM
Big_Shane
Big_Shane
User since 3/26/15

I've always ran my finders off the starting battery. But yes you have a battery issue.

7/28/17 @ 7:29 AM
Hildy Boys
Hildy Boys
User since 12/14/09

Both off the same battery, the fish finder say 10 volts on the display.  Can't tell how much the volts drop when I start the trolling motor because the depth finder turns off.



7/28/17 @ 7:16 AM
nihsif
nihsif
MEMBER since 6/15/01

If they're running off same battery, battery may be weak, low voltage plays havoc with finders... or it could be interference , again,  same battery

DISPLAYING 1 TO 7 OF 7 POSTS
Advertise here
Advertise here
Please take a moment to visit our sponsors. Without them we would not be here.