MENU
Lake-Link Home
LOGIN
Lake-Link
LOG IN

115 Yamaha Running like Crap

8/3/14 @ 12:55 PM
ORIGNAL POST
chopper
User since 7/2/01
Four Stroke - Trolls fine but surges, starts to stall and gets to about half power. I thought it was bad gas so drained that an put in new although I left the tank empty over the winter and might have had condensation. Got any ideas about what I could try before I take it in? Ideas for good places to go or Craigslist type guys that might be good. Thanks.

DISPLAYING 1 TO 6 OF 6 POSTS
FILTER OPTIONS
8/6/14 @ 12:57 PM
wallybeav
wallybeav
User since 11/6/08
Do like they say below and also add couple Cans of Seafoam to gas tank. Did the job for me.

8/5/14 @ 8:59 PM
Storm Chaser
Storm Chaser
User since 7/14/07
Same as Bass, 115 4 stroke with the same trouble. Changed plugs and problem solved.

8/5/14 @ 11:08 AM
BASS EXTREME
User since 10/25/04
I have a 2004 115 4-stroke. It is fuel injection type. Had a similar problem. Changed out the plugs and problem solved.

8/4/14 @ 4:20 PM
poptop
User since 10/1/03
what year is it the earlier yammy four strokes were carbeurated. I had a similar problem with my 90. fresh fuel and filter plus new spark plugs solved the problem

8/3/14 @ 11:40 PM
genek.
User since 8/20/04
you probaly need to clean out the vst and replace the filter on the end of the high pressure pump. when is the last time you changed all the fuel filters? you need to take a fuel pressure check.

DISPLAYING 1 TO 6 OF 6 POSTS
Advertise here
Advertise here
Please take a moment to visit our sponsors. Without them we would not be here.