MENU
Lake-Link Home
LOGIN
Lake-Link
LOG IN
CORONAVIRUS STATEMENT FROM LAKE-LINK

Trolling motor help ASAP!!!!

7/28/19 @ 11:48 AM
ORIGNAL POST
Robbiec21
User since 7/28/19

Foot pedal moves up and down but does not turn drive shaft!!! Everything works cables move , prop works it has power just does not turn drive shaft !!! Any advice please help!!!!

DISPLAYING 1 TO 7 OF 7 POSTS
FILTER OPTIONS
5/23/20 @ 1:46 PM
Tuffy2
MEMBER since 7/7/04

You need a new speed switch, or take the speed control switch out and clean it.

5/23/20 @ 12:54 PM
cheeseshredder
User since 6/1/19

I have a Minn-Kota Maxxum, went to use it this morning and could not turn the speed down. It is stuck wide open, even when dial (on foot pedal) is turned all the way to the off position. Any suggestions would be greatly appreciated, thanks in advance!

7/30/19 @ 9:56 PM
LIL MAN
User since 5/20/08

If it a cable steer ether you broke a cable or you broke the gear. I have one from a guy with half a gear he could figure out why it wouldn't turn.

7/29/19 @ 9:35 PM
wly101
User since 9/26/09

It’s the foot pedal. Borrow one and test it. 

7/28/19 @ 6:49 PM
mattw
mattw
User since 5/6/16

Probably stripped a gear inside the motor, I did that once when I was younger , Dad was not too happy after I did it . See if you can remove top cover to inspect it , but my cents is a gear got stripped 

7/28/19 @ 1:43 PM
BEARBOY
MEMBER since 6/17/01

which trolling motor do you have ?

DISPLAYING 1 TO 7 OF 7 POSTS
Advertise here
Advertise here
Please take a moment to visit our sponsors. Without them we would not be here.