MENU
Lake-Link Home
LOGIN
Lake-Link
LOG IN

Minn Kota Foot Switch

8/4/19 @ 5:52 AM
ORIGNAL POST
Sswpriz
User since 5/8/02

I have a Minn Kota Power Drive V2, twice in the last week, the power to the prop isn't quite right, the switch will rotate the motor left and right, but won't turn the prop, you can hear something clicking, but nothing happens, after playing around with it, then moving the speed control for the prop, it will start working again. Foot switch going bad ??? 

I just replaced that unit two years ago.

Any ideas ?

DISPLAYING 1 TO 6 OF 6 POSTS
FILTER OPTIONS
8/23/19 @ 5:29 PM
LUV2HNT
User since 11/3/03

I have a V2 with auto pilot and US2. I converted it to I-pilot. It was tough at 1st getting use to pauses in casting to steer, but I'm  glad I did it. I still have my foot control in the garage. I've offered my auto pilot to friends and family, but they seem to like the head not pointing in the direction of travel. Lol All foot control issues started after I switched. I think keeping it dry matters also. I always stored mine in the bow compartment and not left out in the elements unless fishing... Get home and turn it upside down if it was raining.

8/23/19 @ 1:10 PM
eyesman
eyesman
User since 1/7/02

I have a Minn Kota power drive with a foot control. The foot control started acting up. It would not run at all in the continuous run setting and was sporadic in the momentary run setting. I took it apart and cleaned the contact strip which only helped a little. On the rocker switch for the continuous/momentary setting there is a white plastic bar that puts pressure on the contact to go between settings. The rocker arm has a cam that depresses that bar. After use the cam get worn down and doesn’t put enough pressure on the contact. I removed the bar and made a cardboard shim to put under the end of the bar that is screwed to the base. Had to experiment with the number of plies of cardboard to make it work. Used cereal box cardboard for the shim. So far so good. 

8/22/19 @ 3:04 PM
Sswpriz
User since 5/8/02

I found a fix that I found online where the magnet that runs over the speed control rheostat, would not work all the time since the rheostat was dirty. Took a Q tip like the guy said, and just used water to clean the rheostat strip, it was filthy, and put everything back together and I haven't had an issue so far. We will see what happens in the long run. Simple 5 minute fix if it works now.

8/4/19 @ 9:59 AM
prop-buster
prop-buster
User since 6/14/05

Gimper is right, they do suck..my foot control quit after two years also. I went with the remote hand held (just plugs right into the system) 10 years ago and haven't had a problem since then...you can run the trolling motor from anywhere in the boat.

8/4/19 @ 6:39 AM
Gimper
User since 11/27/01

Power Drive foot controllers suck. You're lucky you got two years out of it. 

DISPLAYING 1 TO 6 OF 6 POSTS
Advertise here
Advertise here
Please take a moment to visit our sponsors. Without them we would not be here.