MENU
Lake-Link Home
LOGIN
Lake-Link
LOG IN

Etec problem

10/19/21 @ 10:57 PM
ORIGINAL POST
Gill 1774
Gill 1774
USER SINCE 6/17/03

My 2004 75 e tech took a crap today seems like the starter it grinded a little bit and now it doesn't do anything anybody have any quick fixes for that to just get it off the water.


DISPLAYING 1 TO 7 OF 7 POSTS
FILTER OPTIONS

10/23/21 @ 10:13 AM
Gill 1774
Gill 1774
USER SINCE 6/17/03

Brents a great friend always been there for me..Keeps me stocked with ensure to boot.

10/23/21 @ 8:40 AM
Plmlk
Brent Hess
MEMBER SINCE 12/18/07

Good news, we were able to wrap a rope around the fly wheel, and get Gills motor started!

I got off easy, and did not have to tow my buddy in!

I drove to the launch, and Gill picked me up in his Silverado!  He took his sweet time though, he should’ve left some fishing poles in here for me!


The Woodlands Resort
(262) 661-3968
10/20/21 @ 2:29 PM
Carpio
MEMBER SINCE 11/5/17

  CARPIO 

10/20/21 @ 11:05 AM
Plmlk
Brent Hess
MEMBER SINCE 12/18/07

Let me know if you need his number…

The Woodlands Resort
(262) 661-3968
10/20/21 @ 11:03 AM
Plmlk
Brent Hess
MEMBER SINCE 12/18/07

The word on the street is that he appreciated you taking him out crappie fishing last week…

The Woodlands Resort
(262) 661-3968
10/20/21 @ 11:00 AM
Plmlk
Brent Hess
MEMBER SINCE 12/18/07

I’d call your buddy Plmlk…

Just sayin’

If he can’t get it pull started, he’d likely tow your boat to the launch…


The Woodlands Resort
(262) 661-3968
DISPLAYING 1 TO 7 OF 7 POSTS
Advertise here
Advertise here
Please take a moment to visit our sponsors. Without them we would not be here.