MENU Lake-Link.com MORE

60 hp Evinrude Tiller

3/24/19 @ 12:59 PM
ORIGINAL POST
Carpio
Carpio
MEMBER since 11/5/17

Just picked up my new rig. The motor has a new feature which doesn’t require a transom saver. It’s a built in locking device which locks the motor in one place. It won’t tip on its side when trailering. I’ll report on its performance once it’s in the water.    CARPIO 

Post Your Comment
Displaying 1 to 10 of 95 Posts
5/21/19 @ 8:57 PM
Carpio
Carpio
MEMBER since 11/5/17

Well it seems that the problems been solved. Put on about an hour and a half since I got it back.   “ lift pump”.   CARPIO 

Post Your Comment
5/18/19 @ 6:28 PM
Tuffy2
Tuffy2
MEMBER since 7/7/04

I have done much worse, especially as I’m getting older.

Years ago I drove my boat on the trailer at night with the trolling motor down. It didn’t damage the boat, but it did require a new trolling motor.

Edited on 5/18/19 6:31 PM
Post Your Comment
5/18/19 @ 2:23 PM
12packabs
12packabs
USER since 12/19/06

"What a stupid am I...."  Roberto Di Vincenzo...

New Etec has the ignition key on the tiller handle...new place for me to get used to.  Last weekend I killed the motor with the kill button and failed to turn the ignition off.  Sat all week in the on position.

Went to prep my boat for an outing this afternoon, and I was curious why my hydraulic trim/tilt was so slow raising the motor for transport.

At least I discovered this before clogging up a launch ramp.

Plugged her in, there is always tomorrow.  What a dope...

Post Your Comment
5/15/19 @ 9:18 PM
Carpio
Carpio
MEMBER since 11/5/17

Thanks guys,      CARPIO 

Post Your Comment
5/15/19 @ 7:06 PM
Coolhog
Coolhog
USER since 10/7/18

Hope it works out.....my classic with a Yamaha 60 will run 33.8 with 2 guys and full of gas....never tried 1 guy.....hhmmmmm



.

Post Your Comment
5/15/19 @ 4:48 PM
river_chaser
river_chaser
USER since 10/3/12

Good to hear Hope it stays that way

Post Your Comment
5/15/19 @ 4:44 PM
Tuffy2
Tuffy2
MEMBER since 7/7/04

My brothers 165 Escape with a 40 ETec will set you right back in your seat. My Escape with a 30 ETec has a lot of power too.

Glad to hear you got your boat back, now enjoy the rest of the season!

Post Your Comment
5/15/19 @ 2:48 PM
Carpio
Carpio
MEMBER since 11/5/17

I ran it for 45 minutes. It ran perfect!!  Too much power for 1 person in a 16 1/2 footer.         CARPIO 

Post Your Comment
5/15/19 @ 12:04 PM
Carpio
Carpio
MEMBER since 11/5/17

Got my boat back!   They lnstalled a new “ Lift Pump” in the motor,    I’ll run it this PM.      CARPIO 

Post Your Comment
5/5/19 @ 6:20 PM
12packabs
12packabs
USER since 12/19/06

One other note for Carpio...

While running WOT with my new Etec 60HO today, the motor would kick down from 5500rpm to what felt like a governor, holding rpm at 3900-4000.  Ran all the way across the lake (Kegonsa) at 24mph instead of WOT of 34-35.

I turned the unit completely off, restarted, and it ran at 5500rpm WOT again without a hitch.

Not sure I like these computer-controlled engines...


Post Your Comment
Displaying 1 to 10 of 95 Posts