Gmc envoy master mechanic question

10/7/15 @ 5:24 PM
ORIGINAL POST
reeldrag83
reeldrag83
USER since 12/20/12
Here's one fellas. I have a 2003 gmc envoy for no rime or reason all the gauges will just stop working. But if I disconnect positive battery terminal and hook back up everything comes back on. It started doing this a few moths ago so figured battery or ground issue. So replaced battery still did it. Replaced all grounds with new still did it replaced all battery wires still does it. It's so crazy cuz it runs fine voltage test fine just gauges radio Ac and elec Windows stop working. Ecm maybe?
Post Your Comment
Displaying 1 to 10 of 10 Posts
10/9/15 @ 11:24 AM
tiddies1981
tiddies1981
USER since 1/22/15
If you need r&r manual for it let me know. The trailblazers are as bad to do as the older blazers.

Post Your Comment
10/9/15 @ 11:07 AM
reelehooked
reelehooked
USER since 6/22/14
97 blazer that did the same thing and it was the ignition switch, was a real pain in the you know what to isolate the problem and an even bigger one to replace. But once I did it never happened again. If you try to do it yourself, make sure that you get the shop manual. I would not try it without it...

Post Your Comment
10/8/15 @ 1:27 PM
reeldrag83
reeldrag83
USER since 12/20/12
Thanks guys I will keep checking.

Post Your Comment
10/8/15 @ 9:00 AM
tiddies1981
tiddies1981
USER since 1/22/15
Have replaced many clusters on them. But with you saying the radio and a/c quit at the same time makes me think ignition switch. When the symptom occurs ck the voltage on ipc fuse. Should be battery voltage. Also ck orange wire pin d1 and white wire c5 at 48 wire connector under steering column on lower part of dash. If a scanner is available to you scan all systems for codes. Would expect a communication code in 1 or more of the modules.

Post Your Comment
10/8/15 @ 8:28 AM
prop-buster
prop-buster
USER since 6/14/05
My wife has a 2005 Freestyle, the dome light kept coming on driving down the road.... I realize it is the opposite problem you have, but??.....turned out to be the ignition switch.

tech told me the ignition switch it mission control for the whole car, everything goes through it.

just a thought.

Post Your Comment
10/7/15 @ 9:10 PM
bowtech Dee
bowtech Dee
USER since 10/23/12
Envoy had issues with clusters...but you state the radio and ac and windows stop working also?

Post Your Comment
10/7/15 @ 8:17 PM
ayeFeesh
ayeFeesh
USER since 5/17/11
I would've checked fuses before changing all that stuff.

Post Your Comment