Motorguide Xi5 vs Terrova

3/30/15 @ 10:28 AM
ORIGINAL POST
gamehunter
gamehunter
USER since 7/4/09
Has anyone used the new Xi5? Has anyone gone from a terrova to the new Xi5 with pinpoint and tried that vs the ipilot? I am buying soon and can't decide.
Post Your Comment
Displaying 1 to 10 of 38 Posts
4/15/17 @ 10:54 PM
kyl_me
kyl_me
USER since 7/21/08
Glad you got it working. I don't think I used the foot control once last year. I did snap the plastic on the remote that connects to the lanyard. Called MG and they sent me a replacement back cover. Good luck and enjoy the new motor. 

Post Your Comment
4/15/17 @ 10:06 PM
tuggs3
tuggs3
USER since 12/12/08

yes sir. the thing is awesome. was on a powerplant/coolant lake designed to catch wind. forecasted wind was 20MPH. it had to be pushing or over 30 out there with a steady blow. the anchor feature is great. watching my GPS spedometer, it didnt leave 0.0MPH. was pretty cool..and the 80lb thrust is noticeably more than my old 65lb. was able to keep the speed at 1.25-1.5mph into the wind pulling harnesses. fishing on the other hand not so good. but what i expected. walleye dont pick up on this lake till low 60 water temp. was hoping to get some crappie but i only seem to catch crappie when i stumble on to them. im a happy camper with the MG. didnt have the handheld running though. scrambling to get things ready at 5am i left it behind! footpedal was ok..not great, but i see me using the handheld exclusively. 

ive always loved tiller boats. i have a navigator 175 right now. i always thought vertical jigging/backtrolling with a stiff wind was an art and i enjoyed it. but with the anchor feature i dont know how much i will backtroll and jig anymore!

Edited on 4/15/17 10:07 PM
Post Your Comment
4/15/17 @ 6:03 AM
kyl_me
kyl_me
USER since 7/21/08

Don't leave us hanging tuggs, did you get it working?

Post Your Comment
4/14/17 @ 10:43 AM
tuggs3
tuggs3
USER since 12/12/08

awesome. thanks guys, thats a relief. cant wait to get home to get every synced. i was proud of all my electrical work, figuring out the wiring, etc., and thought i was gonna have to strip all the wiring. but im sure it just needs to be deployed. but ya you would think it would mention that in the manual. i didnt see it. 

Edited on 4/14/17 10:45 AM
Post Your Comment
4/14/17 @ 10:32 AM
kyl_me
kyl_me
USER since 7/21/08

I can not find in the manual that it has to be deployed to pair it, but I remeber needing to deploy it in the driveway for some reason (besides wanting to see it run.) Multimeter will tell you the voltage at the plug, that is important at the point.

Good luck, hope it is an easy fix. You will really like that xi5. 

Edited on 4/14/17 10:33 AM
Post Your Comment
4/14/17 @ 9:57 AM
erico
erico
USER since 6/15/01

Yes, I must be deployed for power........


Post Your Comment
4/14/17 @ 7:38 AM
tuggs3
tuggs3
USER since 12/12/08

thanks for the response, kyl. no not deployed. was trying to sync the pedal and remote but nothing. going to pick up a volt meter to confirm power and roll the dice on the water tmrw. hopefully it just needs to be deployed, i was not aware of that. 

Post Your Comment
4/14/17 @ 5:58 AM
kyl_me
kyl_me
USER since 7/21/08

I installed my xi5 last year in place of an Edge unit. I do not recall all those colors for wires going to the plug. I cut the plug from the edge unit, and spliced it to the MG. Do you have power at the receptical? Check with a multi meter. 

also, if I remember correctly, nothing will turn on at the MG head until it is deployed. So if you did not deploy it, do that first to ensure there is no power. 

Post Your Comment
4/13/17 @ 9:03 PM
tuggs3
tuggs3
USER since 12/12/08

sick kid and sick me for last week. got the motorguide mounted, wired up, etc., and its not pulling a charge. I had a 24volt minnkota on there. its on an 06 alumacraft with a plug up front. i wired it to the plug exactly how the minnkota was wired. red line to orange, black to black and the red wire capped. from the plug to the batteries there are 4 lines, an orange and a black/blue stripe going to one battery and a red and black going to the other. exactly how the lines were wired before (put in new batteries).  both + lines have a circuit breaker at battery. pretty sure this is how alumacraft wires them. nothing else connected to the battery but an onboard charger.  any advice? thanks in advance. hoping to get it out this weekend. 

Post Your Comment
3/21/17 @ 9:29 PM
tuggs3
tuggs3
USER since 12/12/08
i ended up going with the motorguide Xi5 (tax return and bday money was in my acct for about a day). here is a random question, but on subject, for the tech guys good with lowrance. my current lowrance is the X27C HD (i think) - GPS, sonar, etc. Can i buy a bare minimum lowrance that can link to the Xi5, put it up front and link it to my antique (5 year old) lowrance in back??? i know my old lowrance has the capability to link to other units to share data. but can i link to a new one that is capable of linking with the Xi5, and control the Xi5 from the back with my old unit?

Post Your Comment
Displaying 1 to 10 of 38 Posts